summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-04-05 15:50:08 (GMT)
committerDavid Young <dyoung@hdfgroup.org>2020-05-20 14:31:57 (GMT)
commitf5dc2a2f8dce02f947694b96e80d0906e8c999e7 (patch)
treec0e32f29c0166e12079d4154f9a2f36f8d64d1c4 /CMakeLists.txt
parent9cc06d671ab355db8dfc65588f6551aed661130e (diff)
downloadhdf5-f5dc2a2f8dce02f947694b96e80d0906e8c999e7.zip
hdf5-f5dc2a2f8dce02f947694b96e80d0906e8c999e7.tar.gz
hdf5-f5dc2a2f8dce02f947694b96e80d0906e8c999e7.tar.bz2
TRILAB-192 add c++ and fortran warnings build systems one file
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2bad805..a82b896 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -961,6 +961,7 @@ set (H5_FC_FUNC_ "H5_FC_FUNC_(name,NAME) name ## _")
if (EXISTS "${HDF5_SOURCE_DIR}/fortran" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/fortran")
option (HDF5_BUILD_FORTRAN "Build FORTRAN support" OFF)
if (HDF5_BUILD_FORTRAN)
+ include (${HDF_RESOURCES_DIR}/HDFFortranCompilerFlags.cmake)
include (${HDF_RESOURCES_EXT_DIR}/HDFUseFortran.cmake)
message (STATUS "Fortran compiler ID is ${CMAKE_Fortran_COMPILER_ID}")