summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2019-08-12 16:24:36 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2019-08-12 16:24:36 (GMT)
commit2d6bb8b95c94c9fc8c52dc779b91d8d6653b730c (patch)
tree28050c25ae1a6ece3f8822f18f2badfc308fa00c /CMakeLists.txt
parente96815ebd83748a4886bf8ef2e80e82df16b9740 (diff)
downloadhdf5-2d6bb8b95c94c9fc8c52dc779b91d8d6653b730c.zip
hdf5-2d6bb8b95c94c9fc8c52dc779b91d8d6653b730c.tar.gz
hdf5-2d6bb8b95c94c9fc8c52dc779b91d8d6653b730c.tar.bz2
Fix API version option
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dc6a94f..488fbab 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -676,7 +676,10 @@ endif ()
#-----------------------------------------------------------------------------
# Option to use 1.12.x API
#-----------------------------------------------------------------------------
-option (HDF5_USE_112_API_DEFAULT "Use the HDF5 1.12.x API by default" ON)
+option (HDF5_USE_112_API_DEFAULT "Use the HDF5 1.12.x API by default" OFF)
+if (NOT HDF5_USE_16_API_DEFAULT AND NOT HDF5_USE_18_API_DEFAULT AND NOT HDF5_USE_110_API_DEFAULT AND NOT HDF5_USE_112_API_DEFAULT)
+ set (HDF5_USE_112_API_DEFAULT ON)
+endif ()
set (H5_USE_112_API_DEFAULT 0)
if (HDF5_USE_112_API_DEFAULT)
set (H5_USE_112_API_DEFAULT 1)