summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2019-02-06 22:41:58 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2019-02-06 22:41:58 (GMT)
commit36e3d1600a3f9d771cfb9b4475f23c57d4b10280 (patch)
tree5d4ce83668315737149ffdd8844dee7365a9bc9e /CMakeLists.txt
parent5ba4266a046b58e8c56ef2f0e26a648e541763b9 (diff)
downloadhdf5-36e3d1600a3f9d771cfb9b4475f23c57d4b10280.zip
hdf5-36e3d1600a3f9d771cfb9b4475f23c57d4b10280.tar.gz
hdf5-36e3d1600a3f9d771cfb9b4475f23c57d4b10280.tar.bz2
Refactor out timeout values
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d6adc9a..b9cdf4d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -758,6 +758,11 @@ if (BUILD_TESTING)
"Timeout in seconds for each test (default 1200=20minutes)"
)
+ # Generate a list of timeouts based on DART_TESTING_TIMEOUT
+ math (EXPR CTEST_SHORT_TIMEOUT "${DART_TESTING_TIMEOUT} / 2")
+ math (EXPR CTEST_LONG_TIMEOUT "${DART_TESTING_TIMEOUT} * 2")
+ math (EXPR CTEST_VERY_LONG_TIMEOUT "${DART_TESTING_TIMEOUT} * 3")
+
option (HDF5_TEST_VFD "Execute tests with different VFDs" OFF)
mark_as_advanced (HDF5_TEST_VFD)
if (HDF5_TEST_VFD)