summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-02-23 22:22:31 (GMT)
committerDavid Young <dyoung@hdfgroup.org>2020-05-20 14:31:55 (GMT)
commit799873706a800e66a9ad8753795a883cc1111486 (patch)
tree86f7cbaecf8696323db237965909d80c762bd027 /CMakeLists.txt
parent60a4987f975b3783e92f36b33ece790acec5dd01 (diff)
downloadhdf5-799873706a800e66a9ad8753795a883cc1111486.zip
hdf5-799873706a800e66a9ad8753795a883cc1111486.tar.gz
hdf5-799873706a800e66a9ad8753795a883cc1111486.tar.bz2
Correct usage of add_compile_definitions
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 487ca18..2bad805 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -564,9 +564,7 @@ endif ()
set (EXE_EXT "")
if (WIN32 OR MINGW)
set (EXE_EXT ".exe")
- add_compile_definitions (-D_BIND_TO_CURRENT_VCLIBS_VERSION=1)
- add_compile_definitions (-D_CRT_SECURE_NO_WARNINGS)
- add_compile_definitions (-D_CONSOLE)
+ add_compile_definitions (_BIND_TO_CURRENT_VCLIBS_VERSION=1 _CRT_SECURE_NO_WARNINGS _CONSOLE)
endif ()
if (MSVC)