summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJordan Henderson <jhenderson@hdfgroup.org>2018-07-31 18:42:19 (GMT)
committerJordan Henderson <jhenderson@hdfgroup.org>2018-07-31 18:42:19 (GMT)
commit9aa2eaeb9ed9c94f63973cb55f13de256558497c (patch)
treebfa28bf339ec7a0536a65663292a9c55d311bdee /CMakeLists.txt
parent5e138dc1e91a4ec61d9383397e0e11c6bbbcbe5e (diff)
downloadhdf5-9aa2eaeb9ed9c94f63973cb55f13de256558497c.zip
hdf5-9aa2eaeb9ed9c94f63973cb55f13de256558497c.tar.gz
hdf5-9aa2eaeb9ed9c94f63973cb55f13de256558497c.tar.bz2
Add Autotools and CMake checks for big I/O MPI-3 functions
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0302f4f..40f8eb2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -569,6 +569,16 @@ if (HDF5_ENABLE_PARALLEL)
Parallel writes of filtered data will be disabled.")
set (PARALLEL_FILTERED_WRITES OFF)
endif ()
+
+ # Used by big I/O feature
+ set (LARGE_PARALLEL_IO ON)
+ CHECK_SYMBOL_EXISTS (MPI_Get_elements_x "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_Get_elements_x)
+ CHECK_SYMBOL_EXISTS (MPI_Type_size_x "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_Type_size_x)
+ if (NOT H5_HAVE_MPI_Get_elements_x OR NOT H5_HAVE_MPI_Type_size_x)
+ message (WARNING "The MPI_Get_elements_x and/or MPI_Type_size_x functions could not be located.
+ Reading/Writing >2GB of data in a single parallel I/O operation will be disabled.")
+ set (LARGE_PARALLEL_IO OFF)
+ endif ()
else ()
message (STATUS "Parallel libraries not found")
endif ()