summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-10-15 18:16:53 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-10-15 18:16:53 (GMT)
commit9f6fb53aa6941dbc67e40f47c8e27a12255cd123 (patch)
tree1a24a46fd9472c538e5bedc58b8024f5e0a9ec76 /CMakeLists.txt
parent3e7926a35ba7688faf6d755e982bdbbd46aaf7e9 (diff)
downloadhdf5-9f6fb53aa6941dbc67e40f47c8e27a12255cd123.zip
hdf5-9f6fb53aa6941dbc67e40f47c8e27a12255cd123.tar.gz
hdf5-9f6fb53aa6941dbc67e40f47c8e27a12255cd123.tar.bz2
[svn-r19613] Add option command to set flags OFF for if not using ExternalProjects
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 22b0f1e..10503ac 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -445,6 +445,8 @@ HDF5_SETUP_FILTERS (SCALEOFFSET)
INCLUDE (ExternalProject)
OPTION (HDF5_ALLOW_EXTERNAL_SUPPORT "Allow External Library Building" "NO")
+OPTION (ZLIB_USE_EXTERNAL "Use External Library Building for ZLIB" 0)
+OPTION (SZIP_USE_EXTERNAL "Use External Library Building for SZIP" 0)
IF (HDF5_ALLOW_EXTERNAL_SUPPORT MATCHES "SVN")
SET (ZLIB_USE_EXTERNAL 1)
SET (SZIP_USE_EXTERNAL 1)