summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVailin Choi <vchoi@hdfgroup.org>2014-06-09 16:19:26 (GMT)
committerVailin Choi <vchoi@hdfgroup.org>2014-06-09 16:19:26 (GMT)
commit519e23171052963775c47132ec0106727fdf5c41 (patch)
treecf7c6da9e0f28cf28632d596901ff5989f5b6401 /CMakeLists.txt
parent94d9aa2d319addf02c456d9f1b4551004d5e4a38 (diff)
downloadhdf5-519e23171052963775c47132ec0106727fdf5c41.zip
hdf5-519e23171052963775c47132ec0106727fdf5c41.tar.gz
hdf5-519e23171052963775c47132ec0106727fdf5c41.tar.bz2
[svn-r25242] Bring revisions #24505 - #24670 from trunk to revise_chunks.
Tested on jam, ostrich, koala, platypus.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 8 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index da003c5..d443d78 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -283,6 +283,9 @@ ELSE (BUILD_SHARED_LIBS)
IF (NOT WIN32)
# should this be a user setting : Everyone uses it anyway ?
ADD_DEFINITIONS (-DPIC)
+ IF (${CMAKE_SYSTEM_NAME} MATCHES "SunOS")
+ ADD_DEFINITIONS (-KPIC)
+ ENDIF (${CMAKE_SYSTEM_NAME} MATCHES "SunOS")
ENDIF (NOT WIN32)
ENDIF (BUILD_SHARED_LIBS)
@@ -461,7 +464,11 @@ ENDIF (HDF5_DISABLE_COMPILER_WARNINGS)
# break into groups (from the config/gnu-flags file)
#-----------------------------------------------------------------------------
IF (NOT MSVC)
- SET (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -W -Wundef -Wshadow -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wwrite-strings -Wconversion -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls -Wnested-externs -Winline")
+ IF (NOT ${CMAKE_SYSTEM_NAME} MATCHES "SunOS")
+ SET (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wextra -Wundef -Wshadow -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wwrite-strings -Wconversion -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls -Wnested-externs -Winline")
+ ELSE (NOT ${CMAKE_SYSTEM_NAME} MATCHES "SunOS")
+ SET (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -erroff=%none -DBSD_COMP")
+ ENDIF (NOT ${CMAKE_SYSTEM_NAME} MATCHES "SunOS")
# Append warning flags
# Don't use the '-Wtraditional' flag, we're way past having K&R C code
# SET (H5_CFLAGS "${H5_CFLAGS} -Wtraditional")
@@ -753,14 +760,6 @@ IF (HDF5_ALLOW_EXTERNAL_SUPPORT MATCHES "SVN" OR HDF5_ALLOW_EXTERNAL_SUPPORT MAT
ENDIF (HDF5_ALLOW_EXTERNAL_SUPPORT MATCHES "SVN" OR HDF5_ALLOW_EXTERNAL_SUPPORT MATCHES "TGZ")
#-----------------------------------------------------------------------------
-# Build utility to copy and strip X lines of file
-#-----------------------------------------------------------------------------
-IF (HDF5_BUILD_TOOLS AND BUILD_TESTING)
- SET (XLATE_UTILITY "xlatefile")
- ADD_EXECUTABLE(${XLATE_UTILITY} ${HDF5_RESOURCES_DIR}/xlatefile.c)
-ENDIF (HDF5_BUILD_TOOLS AND BUILD_TESTING)
-
-#-----------------------------------------------------------------------------
# Dashboard and Testing Settings
#-----------------------------------------------------------------------------
OPTION (BUILD_TESTING "Build HDF5 Unit Testing" OFF)