summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2021-10-29 12:48:52 (GMT)
committerGitHub <noreply@github.com>2021-10-29 12:48:52 (GMT)
commit68d810d0d28668b3845cd9186b8947b47f7454e0 (patch)
tree3e674f005ef004449c29af38443506f6d74f8be8 /CMakeLists.txt
parenta931934fa793ceeb8334e365de225bfd1b67c92a (diff)
downloadhdf5-68d810d0d28668b3845cd9186b8947b47f7454e0.zip
hdf5-68d810d0d28668b3845cd9186b8947b47f7454e0.tar.gz
hdf5-68d810d0d28668b3845cd9186b8947b47f7454e0.tar.bz2
1.10 Merge Consolidate VFD create list macro #1132 (#1140)
* Merge Consolidate VFD create list macro #1132 * Split dir create into separate macro * fix VFD settings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8036522..b3daf95 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -919,6 +919,9 @@ if (BUILD_TESTING)
if (HDF5_TEST_VFD)
option (HDF5_TEST_FHEAP_VFD "Execute tests with different VFDs" ON)
mark_as_advanced (HDF5_TEST_FHEAP_VFD)
+
+ # Initialize the list of VFDs to be used for testing and create a test folder for each VFD
+ H5_SET_VFD_LIST()
endif ()
option (HDF_TEST_EXPRESS "Control testing framework (0-3)" "0")