summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorjhendersonHDF <jhenderson@hdfgroup.org>2023-04-08 01:11:01 (GMT)
committerGitHub <noreply@github.com>2023-04-08 01:11:01 (GMT)
commitde9fab17e1c256e2ab9eb6920da50c9d5d3e6c95 (patch)
tree5a4f4fcc856fd46a59f952f3d686762023aa0d8e /CMakeLists.txt
parentbc2517b33d8bd5d23c2352d38b97a23d07c92833 (diff)
downloadhdf5-de9fab17e1c256e2ab9eb6920da50c9d5d3e6c95.zip
hdf5-de9fab17e1c256e2ab9eb6920da50c9d5d3e6c95.tar.gz
hdf5-de9fab17e1c256e2ab9eb6920da50c9d5d3e6c95.tar.bz2
CMake - Match Autotools behavior for library instrumentation (#2648) (#2672)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fb0a69d..20db72e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -647,9 +647,15 @@ option (HDF5_BUILD_GENERATORS "Build Test Generators" OFF)
#-----------------------------------------------------------------------------
option (HDF5_ENABLE_TRACE "Enable API tracing capability" OFF)
mark_as_advanced (HDF5_ENABLE_TRACE)
-if (${HDF_CFG_NAME} MATCHES "Debug")
+if (${HDF_CFG_NAME} MATCHES "Debug" OR ${HDF_CFG_NAME} MATCHES "Developer")
# Enable instrumenting of the library's internal operations
option (HDF5_ENABLE_INSTRUMENT "Instrument The library" OFF)
+
+ # Instrumenting is enabled by default for parallel debug builds
+ if (HDF5_ENABLE_PARALLEL)
+ set (HDF5_ENABLE_INSTRUMENT ON CACHE BOOL "Instrument The library" FORCE)
+ endif ()
+
if (HDF5_ENABLE_INSTRUMENT)
set (H5_HAVE_INSTRUMENTED_LIBRARY 1)
endif ()