summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2014-04-22 18:41:11 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2014-04-22 18:41:11 (GMT)
commit2b11123a200e4595f8bd563476486987c6cc03f4 (patch)
tree6402865aff813ca8d338b2260dcb5867c13ae7f5 /CMakeLists.txt
parenta75e8dd654268ba1dd35abf3a78da2f115802029 (diff)
downloadhdf5-2b11123a200e4595f8bd563476486987c6cc03f4.zip
hdf5-2b11123a200e4595f8bd563476486987c6cc03f4.tar.gz
hdf5-2b11123a200e4595f8bd563476486987c6cc03f4.tar.bz2
[svn-r25075] Correct the install folder logic.
Tested: local linux and Mac
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 0 insertions, 16 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 106c59c..ea6f945 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -213,22 +213,6 @@ set (HDF5_PACKAGE_URL "http://www.hdfgroup.org")
set (HDF5_PACKAGE_BUGREPORT "help@hdfgroup.org")
#-----------------------------------------------------------------------------
-# Set Install folder value
-#-----------------------------------------------------------------------------
-if (CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
- if (CMAKE_HOST_UNIX)
- set (CMAKE_INSTALL_PREFIX "/HDF_Group/${HDF5_PACKAGE_NAME}/${HDF5_PACKAGE_VERSION}"
- CACHE PATH "Install path prefix, prepended onto install directories." FORCE)
- else (CMAKE_HOST_UNIX)
- GetDefaultWindowsPrefixBase(CMAKE_GENERIC_PROGRAM_FILES)
- set (CMAKE_INSTALL_PREFIX
- "${CMAKE_GENERIC_PROGRAM_FILES}/HDF_Group/${HDF5_PACKAGE_NAME}/${HDF5_PACKAGE_VERSION}"
- CACHE PATH "Install path prefix, prepended onto install directories." FORCE)
- set (CMAKE_GENERIC_PROGRAM_FILES)
- endif (CMAKE_HOST_UNIX)
-endif (CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
-
-#-----------------------------------------------------------------------------
# Include some macros for reusable code
#-----------------------------------------------------------------------------
include (${HDF5_RESOURCES_DIR}/HDFMacros.cmake)