summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2013-08-09 14:55:22 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2013-08-09 14:55:22 (GMT)
commitf1bb1129f374aefd518d5e42ff5e8d27f376bda4 (patch)
tree758073ad4f02c0c9bb5e47911ddc697cef8708d2 /CMakeLists.txt
parent111a57ca261c0145d6d1216809c448f98925b4aa (diff)
downloadhdf5-f1bb1129f374aefd518d5e42ff5e8d27f376bda4.zip
hdf5-f1bb1129f374aefd518d5e42ff5e8d27f376bda4.tar.gz
hdf5-f1bb1129f374aefd518d5e42ff5e8d27f376bda4.tar.bz2
[svn-r23979] Correct Packaging var names.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dc6e383..577f8ff 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1230,12 +1230,12 @@ IF (NOT HDF5_EXTERNALLY_CONFIGURED AND NOT HDF5_NO_PACKAGES)
# Configure the Info.plist file for the install bundle
#-----------------------------------------------------------------------------
CONFIGURE_FILE (
- ${CMAKE_ROOT}/Modules/CPack.Info.plist.in
+ ${HDF5_RESOURCES_DIR}/CPack.Info.plist.in
${HDF5_BINARY_DIR}/CMakeFiles/Info.plist @ONLY
)
- SET (CMAKE_BUNDLE_NAME "${HDF5_PACKAGE_STRING}")
- SET (CMAKE_BUNDLE_LOCATION "/") # make sure CMAKE_INSTALL_PREFIX ends in /
- SET (CMAKE_INSTALL_PREFIX "/${CMAKE_BUNDLE_NAME}.framework/Versions/${CPACK_PACKAGE_VERSION}/${CPACK_PACKAGE_NAME}")
+ SET (CPACK_BUNDLE_NAME "${HDF5_PACKAGE_STRING}")
+ SET (CPACK_BUNDLE_LOCATION "/") # make sure CMAKE_INSTALL_PREFIX ends in /
+ SET (CMAKE_INSTALL_PREFIX "/${CPACK_BUNDLE_NAME}.framework/Versions/${CPACK_PACKAGE_VERSION}/${CPACK_PACKAGE_NAME}/")
SET (CPACK_BUNDLE_ICON "${HDF5_RESOURCES_DIR}/hdf.gif")
SET (CPACK_BUNDLE_PLIST "${HDF5_BINARY_DIR}/CMakeFiles/Info.plist")
# SET (CPACK_BUNDLE_STARTUP_COMMAND "${HDF5_BINARY_DIR}/CMakeFiles/${HDF5_PACKAGE}${HDF_PACKAGE_EXT}-startup.sh")