summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2013-09-13 19:22:57 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2013-09-13 19:22:57 (GMT)
commitf6949a66d7bef00c15ee7542f3e3503ffae75877 (patch)
tree94b21b462e97a8f2338a627bbbd24816dfe06967 /CMakeLists.txt
parent06828464790a100546de1cbb2a52ae6a33f67e32 (diff)
downloadhdf5-f6949a66d7bef00c15ee7542f3e3503ffae75877.zip
hdf5-f6949a66d7bef00c15ee7542f3e3503ffae75877.tar.gz
hdf5-f6949a66d7bef00c15ee7542f3e3503ffae75877.tar.bz2
[svn-r24136] Add base set of warnings for gcc
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7ddc562..fde7616 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -460,6 +460,7 @@ ENDIF (HDF5_DISABLE_COMPILER_WARNINGS)
# break into groups (from the config/gnu-flags file)
#-----------------------------------------------------------------------------
IF (NOT MSVC)
+ SET (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -W -Wundef -Wshadow -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wwrite-strings -Wconversion -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls -Wnested-externs -Winline")
# Append warning flags
# Don't use the '-Wtraditional' flag, we're way past having K&R C code
# SET (H5_CFLAGS "${H5_CFLAGS} -Wtraditional")