summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2019-02-04 07:47:51 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2019-02-04 07:47:51 (GMT)
commit12fc6bf95507244b2f18a56f8ff76cc0ea922fea (patch)
tree0c7ac702a931646e4e0cbdd01dc1f1e571c07f2a /CMakeLists.txt
parentae94128b328236cbb36c1da005e2211b5154d2b9 (diff)
downloadhdf5-12fc6bf95507244b2f18a56f8ff76cc0ea922fea.zip
hdf5-12fc6bf95507244b2f18a56f8ff76cc0ea922fea.tar.gz
hdf5-12fc6bf95507244b2f18a56f8ff76cc0ea922fea.tar.bz2
Merge of changes from develop for 1.10.5.
Added RELEASE.txt entries for new features.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f1603f0..7b1a3ba 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -482,6 +482,15 @@ if (HDF5_MEMORY_ALLOC_SANITY_CHECK)
endif ()
#-----------------------------------------------------------------------------
+# Option to enable/disable using pread/pwrite for VFDs
+#-----------------------------------------------------------------------------
+option (HDF5_ENABLE_PREADWRITE "Use pread/pwrite in sec2/log/core VFDs in place of read/write (when available)" ON)
+mark_as_advanced (HDF5_ENABLE_PREADWRITE)
+if (HDF5_ENABLE_PREADWRITE AND H5_HAVE_PREAD AND H5_HAVE_PWRITE)
+ set (H5_HAVE_PREADWRITE 1)
+endif ()
+
+#-----------------------------------------------------------------------------
# Option to use deprecated public API symbols
#-----------------------------------------------------------------------------
option (HDF5_ENABLE_DEPRECATED_SYMBOLS "Enable deprecated public API symbols" ON)