summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2019-08-12 16:26:41 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2019-08-12 16:26:50 (GMT)
commit7322752ab1084fad116052d38de633afb8a55f00 (patch)
treeeaaad72ac34add2f7806261663a4b0ae724f504a /CMakeLists.txt
parentf0650549ac0f0eeab973bb9a5ea63a46ece5dcda (diff)
downloadhdf5-7322752ab1084fad116052d38de633afb8a55f00.zip
hdf5-7322752ab1084fad116052d38de633afb8a55f00.tar.gz
hdf5-7322752ab1084fad116052d38de633afb8a55f00.tar.bz2
Fix API version option
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d8a629e..ae67120 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -645,7 +645,10 @@ endif ()
#-----------------------------------------------------------------------------
# Option to use 1.10.x API
#-----------------------------------------------------------------------------
-option (HDF5_USE_110_API_DEFAULT "Use the HDF5 1.10.x API by default" ON)
+option (HDF5_USE_110_API_DEFAULT "Use the HDF5 1.10.x API by default" OFF)
+if (NOT HDF5_USE_16_API_DEFAULT AND NOT HDF5_USE_18_API_DEFAULT AND NOT HDF5_USE_110_API_DEFAULT)
+ set (HDF5_USE_110_API_DEFAULT ON)
+endif ()
set (H5_USE_110_API_DEFAULT 0)
if (HDF5_USE_110_API_DEFAULT)
set (H5_USE_110_API_DEFAULT 1)