summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJordan Henderson <jhenderson@hdfgroup.org>2018-07-31 15:45:43 (GMT)
committerJordan Henderson <jhenderson@hdfgroup.org>2018-08-02 14:47:26 (GMT)
commit7a4025f25916c241289ec0b97baad4c9c29241aa (patch)
tree033ab1d630f43a885325cadc5b550fd109848f57 /CMakeLists.txt
parentd4298589fe3260be28a7a2112b48796a217a039a (diff)
downloadhdf5-7a4025f25916c241289ec0b97baad4c9c29241aa.zip
hdf5-7a4025f25916c241289ec0b97baad4c9c29241aa.tar.gz
hdf5-7a4025f25916c241289ec0b97baad4c9c29241aa.tar.bz2
Add hdf5settings section for parallel compression status in CMake builds
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6a7ac91..e4b3990 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -561,11 +561,13 @@ if (HDF5_ENABLE_PARALLEL)
CHECK_SYMBOL_EXISTS (MPI_Info_c2f "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_MULTI_LANG_Info)
# Used by Parallel Compression feature
+ set (PARALLEL_FILTERED_WRITES ON)
CHECK_SYMBOL_EXISTS (MPI_Mprobe "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_Mprobe)
CHECK_SYMBOL_EXISTS (MPI_Imrecv "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_Imrecv)
if (NOT H5_HAVE_MPI_Mprobe OR NOT H5_HAVE_MPI_Imrecv)
message (WARNING "The MPI_Mprobe and/or MPI_Imrecv functions could not be located.
Parallel writes of filtered data will be disabled.")
+ set (PARALLEL_FILTERED_WRITES OFF)
endif ()
else ()
message (STATUS "Parallel libraries not found")