summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@koziol.gov>2019-07-30 20:35:45 (GMT)
committerQuincey Koziol <koziol@koziol.gov>2019-07-30 20:35:45 (GMT)
commit00fe4ccf308586f5bb4fbd146174a9d4907f4cf1 (patch)
tree4425932f1e1353a2626a1ad185254b0748042e72 /CMakeLists.txt
parent605889fde8a92ed902bb4c5207912d1d687f7a99 (diff)
parentc21ba9c26e946f08c201f16f56cdfb4797e9e55c (diff)
downloadhdf5-00fe4ccf308586f5bb4fbd146174a9d4907f4cf1.zip
hdf5-00fe4ccf308586f5bb4fbd146174a9d4907f4cf1.tar.gz
hdf5-00fe4ccf308586f5bb4fbd146174a9d4907f4cf1.tar.bz2
Merge branch 'develop' of https://bitbucket.hdfgroup.org/scm/~koziol/hdf5 into develop
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 95d24bb..dc6a94f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -574,6 +574,27 @@ include (${HDF_RESOURCES_DIR}/HDFCompilerFlags.cmake)
set (CMAKE_MODULE_PATH ${HDF_RESOURCES_DIR} ${HDF_RESOURCES_EXT_DIR} ${CMAKE_MODULE_PATH})
#-----------------------------------------------------------------------------
+# Option to Enable HDFS
+#-----------------------------------------------------------------------------
+option (HDF5_ENABLE_HDFS "Enable HDFS" OFF)
+if (HDF5_ENABLE_HDFS)
+ find_package(JNI REQUIRED)
+ if (JNI_FOUND)
+ set (H5_HAVE_LIBJVM 1)
+ endif ()
+ find_package(HDFS REQUIRED)
+ if (HDFS_FOUND)
+ set (H5_HAVE_LIBHDFS 1)
+ set (H5_HAVE_HDFS_H 1)
+ if (NOT MSVC)
+ list (APPEND LINK_LIBS -pthread)
+ endif ()
+ else ()
+ message (FATAL_ERROR "Set to use libhdfs library, but could not find or use libhdfs. Please verify that the path to HADOOP_HOME is valid, and/or reconfigure without HDF5_ENABLE_HDFS")
+ endif ()
+endif ()
+
+#-----------------------------------------------------------------------------
# Option to Enable MPI Parallel
#-----------------------------------------------------------------------------
option (HDF5_ENABLE_PARALLEL "Enable parallel build (requires MPI)" OFF)