summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2020-11-14 17:58:52 (GMT)
committerGitHub <noreply@github.com>2020-11-14 17:58:52 (GMT)
commitec48fb8dfdb4f2f59f22a5efb6b950aafcac449d (patch)
treec7f15d0a91a22d3340a189ecb680ec21a571bd53 /CMakeLists.txt
parent5b0b132fb0118caba14998df7544fca329939160 (diff)
parent01153cef8b2ce42b4bb7c1f0db6da9cee0a1edf1 (diff)
downloadhdf5-ec48fb8dfdb4f2f59f22a5efb6b950aafcac449d.zip
hdf5-ec48fb8dfdb4f2f59f22a5efb6b950aafcac449d.tar.gz
hdf5-ec48fb8dfdb4f2f59f22a5efb6b950aafcac449d.tar.bz2
Merge pull request #89 from byrnHDF/hdf5_1_12
Hdf5 1 12 doxygen support framework
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1e8664d..e7fddae 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -225,6 +225,7 @@ set (HDF5_JAVA_LIB_DIR ${HDF5_SOURCE_DIR}/java/lib)
set (HDF5_JAVA_LOGGING_JAR ${HDF5_SOURCE_DIR}/java/lib/slf4j-api-1.7.25.jar)
set (HDF5_JAVA_LOGGING_NOP_JAR ${HDF5_SOURCE_DIR}/java/lib/ext/slf4j-nop-1.7.25.jar)
set (HDF5_JAVA_LOGGING_SIMPLE_JAR ${HDF5_SOURCE_DIR}/java/lib/ext/slf4j-simple-1.7.25.jar)
+set (HDF5_DOXYGEN_DIR ${HDF5_SOURCE_DIR}/doxygen)
#-----------------------------------------------------------------------------
# parse the full version number from H5public.h and include in H5_VERS_INFO
@@ -532,6 +533,20 @@ endif ()
# endif ()
#-----------------------------------------------------------------------------
+# Option to build documentation
+#-----------------------------------------------------------------------------
+option (HDF5_BUILD_DOC "Build documentation" OFF)
+if (HDF5_BUILD_DOC AND EXISTS "${HDF5_DOXYGEN_DIR}" AND IS_DIRECTORY "${HDF5_DOXYGEN_DIR}")
+# check if Doxygen is installed
+ find_package(Doxygen)
+ if (DOXYGEN_FOUND)
+ message(STATUS "Doxygen version: ${DOXYGEN_VERSION}")
+ else ()
+ message(STATUS "Doxygen needs to be installed to generate the doxygen documentation")
+ endif ()
+endif ()
+
+#-----------------------------------------------------------------------------
# Option to indicate using a memory checker
#-----------------------------------------------------------------------------
option (HDF5_ENABLE_USING_MEMCHECKER "Indicate that a memory checker is used" OFF)