summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2020-11-02 13:44:44 (GMT)
committerGitHub <noreply@github.com>2020-11-02 13:44:44 (GMT)
commitdc47bb7084d55993a0a6f3725dcf79d92d7f0e65 (patch)
treeb9dc4be8a9b87d3b21057d63b533e43d47ed643e /CMakeLists.txt
parent3c42c49a02227a4d43504d9da7cf3df5b34f98ee (diff)
parent7259b5eb7ac291f00cc989a44c5fe4964759efaf (diff)
downloadhdf5-dc47bb7084d55993a0a6f3725dcf79d92d7f0e65.zip
hdf5-dc47bb7084d55993a0a6f3725dcf79d92d7f0e65.tar.gz
hdf5-dc47bb7084d55993a0a6f3725dcf79d92d7f0e65.tar.bz2
Merge pull request #69 from xantares/mingw3
CMake: Add an option to opt-out static libgcc
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 01355dd..43088b0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -579,6 +579,8 @@ if (WIN32)
endif ()
endif ()
+option (HDF5_MINGW_STATIC_GCC_LIBS "Statically link libgcc/libstdc++" OFF)
+
if (MSVC)
set (CMAKE_MFC_FLAG 0)
set (WIN_COMPILE_FLAGS "")