summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2022-11-03 23:30:08 (GMT)
committerGitHub <noreply@github.com>2022-11-03 23:30:08 (GMT)
commit018f093c096cca8b3965eb17afa01f5637317995 (patch)
tree6bd8c321decf7e544dd2dbf86976c51dc8407e92 /CMakeLists.txt
parent40a0e3c7b5b30912ddbe4cf58f289575d63fef12 (diff)
downloadhdf5-018f093c096cca8b3965eb17afa01f5637317995.zip
hdf5-018f093c096cca8b3965eb17afa01f5637317995.tar.gz
hdf5-018f093c096cca8b3965eb17afa01f5637317995.tar.bz2
Removes the memory allocation sanity checks feature (#2218)
* Removes the memory allocation sanity checks feature * Committing clang-format changes * Removes zero size checks for H5MM_(c|m)alloc() * Explicitly return NULL when size == 0 in H5allocate_memory() * Committing clang-format changes * Format fix Co-authored-by: github-actions <41898282+github-actions[bot]@users.noreply.github.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 0 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 15caa32..1148f2d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -561,14 +561,6 @@ if (HDF5_ENABLE_USING_MEMCHECKER)
endif ()
#-----------------------------------------------------------------------------
-# Option to indicate internal memory allocation sanity checks are enabled
-#-----------------------------------------------------------------------------
-option (HDF5_MEMORY_ALLOC_SANITY_CHECK "Indicate that internal memory allocation sanity checks are enabled" OFF)
-if (HDF5_MEMORY_ALLOC_SANITY_CHECK)
- set (H5_MEMORY_ALLOC_SANITY_CHECK 1)
-endif ()
-
-#-----------------------------------------------------------------------------
# Option to enable/disable using pread/pwrite for VFDs
#-----------------------------------------------------------------------------
option (HDF5_ENABLE_PREADWRITE "Use pread/pwrite in sec2/log/core VFDs in place of read/write (when available)" ON)