summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-01-30 22:03:03 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-01-30 22:03:03 (GMT)
commit435fd5afa57eb8c3157600431f0c8d4df6257cd4 (patch)
tree52c2016563e20ecacabf7cad45a2226306ec0365 /CMakeLists.txt
parent1711c3727e11d41268da1c6d4ae0204e081c5e1d (diff)
downloadhdf5-435fd5afa57eb8c3157600431f0c8d4df6257cd4.zip
hdf5-435fd5afa57eb8c3157600431f0c8d4df6257cd4.tar.gz
hdf5-435fd5afa57eb8c3157600431f0c8d4df6257cd4.tar.bz2
HDFFV-10398 add support for Emscriptem build system
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ee5fc2a..00ec70a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -528,9 +528,13 @@ endif ()
#-----------------------------------------------------------------------------
# Option to embed library info into executables
#-----------------------------------------------------------------------------
-option (HDF5_ENABLE_EMBEDDED_LIBINFO "embed library info into executables" ON)
-if (HDF5_ENABLE_EMBEDDED_LIBINFO)
- set (H5_HAVE_EMBEDDED_LIBINFO 1)
+if (CMAKE_SYSTEM_NAME STREQUAL "Emscripten")
+ set (H5_HAVE_EMBEDDED_LIBINFO 0)
+else ()
+ option (HDF5_ENABLE_EMBEDDED_LIBINFO "embed library info into executables" ON)
+ if (HDF5_ENABLE_EMBEDDED_LIBINFO)
+ set (H5_HAVE_EMBEDDED_LIBINFO 1)
+ endif ()
endif ()
include (${HDF_RESOURCES_DIR}/HDFCompilerFlags.cmake)