summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2019-08-13 08:36:42 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2019-08-13 08:36:42 (GMT)
commit5b6bd7c922d81bb6d1877c03e4b012823f03f88a (patch)
tree0b2564076409a5203df189a480f5cd6471aa57e1 /CMakeLists.txt
parente874070dbb27994b24860f94ffc53ca1b12211fa (diff)
downloadhdf5-5b6bd7c922d81bb6d1877c03e4b012823f03f88a.zip
hdf5-5b6bd7c922d81bb6d1877c03e4b012823f03f88a.tar.gz
hdf5-5b6bd7c922d81bb6d1877c03e4b012823f03f88a.tar.bz2
Added the map (H5M) API
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 374e15e..e6474aa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -705,6 +705,7 @@ if (NOT HDF5_EXTERNALLY_CONFIGURED)
endif ()
endif ()
endif ()
+
#-----------------------------------------------------------------------------
# Option to use threadsafe
#-----------------------------------------------------------------------------
@@ -759,6 +760,11 @@ if (HDF5_ENABLE_THREADSAFE)
endif ()
#-----------------------------------------------------------------------------
+# Option to build the map API
+#-----------------------------------------------------------------------------
+option (HDF5_ENABLE_MAP_API "Build the map API" OFF)
+
+#-----------------------------------------------------------------------------
# Add the HDF5 Library Target to the build
#-----------------------------------------------------------------------------
add_subdirectory (src)