summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorjhendersonHDF <jhenderson@hdfgroup.org>2023-07-27 19:11:28 (GMT)
committerGitHub <noreply@github.com>2023-07-27 19:11:28 (GMT)
commit17a5a1a37ccc851ca9123b2921fbae15c4814edf (patch)
treebdc30fe342f691bd8c0d2454a81a195b4d31cef9 /CMakeLists.txt
parent144bec301c874554cdd8651148dede93fd5279dc (diff)
downloadhdf5-17a5a1a37ccc851ca9123b2921fbae15c4814edf.zip
hdf5-17a5a1a37ccc851ca9123b2921fbae15c4814edf.tar.gz
hdf5-17a5a1a37ccc851ca9123b2921fbae15c4814edf.tar.bz2
Subfiling VFD source cleanup (#3241) (#3290)
* Subfiling VFD source cleanup (#3241) * Subfiling VFD source cleanup Modularize Subfiling CMake code into separate CMakeLists.txt file Update Mercury util code to latest version and update Copyright Generate mercury_util_config.h header file instead of using pre-generated file Remove unnecessary Mercury functionality Fix minor warning in Subfiling VFD code * Remove Mercury headers from Autotools publicly-distributed header list * Fix CMake builds when Subfiling VFD isn't enabled (#3250) * Fix CMake builds when Subfiling VFD isn't enabled * Add Subfiling VFD entry to hdf5-config.cmake.in
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 15 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c76bfd8..ebd45c8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -760,8 +760,22 @@ if (HDF5_ENABLE_SUBFILING_VFD)
${HDF5_SRC_INCLUDE_DIRS}
${H5FD_SUBFILING_MERCURY_DIR}
)
- set (H5_HAVE_MERCURY_H 1)
set (CMAKE_REQUIRED_INCLUDES "${H5FD_SUBFILING_MERCURY_DIR}")
+
+ # Run some configure checks for the Mercury util files
+ set (CMAKE_EXTRA_INCLUDE_FILES pthread.h)
+ set (CMAKE_REQUIRED_LIBRARIES ${CMAKE_THREAD_LIBS_INIT})
+
+ check_type_size(PTHREAD_MUTEX_ADAPTIVE_NP PTHREAD_MUTEX_ADAPTIVE_NP_SIZE)
+ if (HAVE_PTHREAD_MUTEX_ADAPTIVE_NP_SIZE)
+ set (${HDF_PREFIX}_HAVE_PTHREAD_MUTEX_ADAPTIVE_NP 1)
+ endif ()
+
+ check_symbol_exists(pthread_condattr_setclock pthread.h
+ ${HDF_PREFIX}_HAVE_PTHREAD_CONDATTR_SETCLOCK)
+
+ unset (CMAKE_EXTRA_INCLUDE_FILES)
+ unset (CMAKE_REQUIRED_LIBRARIES)
endif()
#option (DEFAULT_API_VERSION "Enable v1.14 API (v16, v18, v110, v112, v114)" "v114")