summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-10-19 18:49:33 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-10-19 18:49:33 (GMT)
commit5f99891e6dc59524fb6e43ca96a86df22b403c61 (patch)
tree53a165ebcedf95379341dfbd9b43ca15732e0a5d /CMakeLists.txt
parent4e575a086553a23fc79d3e92f48eb9508711e6ca (diff)
parent494d39f1c2f6225c732cb857c860d6b475d03226 (diff)
downloadhdf5-5f99891e6dc59524fb6e43ca96a86df22b403c61.zip
hdf5-5f99891e6dc59524fb6e43ca96a86df22b403c61.tar.gz
hdf5-5f99891e6dc59524fb6e43ca96a86df22b403c61.tar.bz2
Merge pull request #1299 in HDFFV/hdf5 from ~BYRN/hdf5_merge_adb:develop to develop
* commit '494d39f1c2f6225c732cb857c860d6b475d03226': Move options to root cmake file EED-258 Add modules uses toolchain files
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 53cddf7..e2fb000 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -913,4 +913,10 @@ endif ()
#-----------------------------------------------------------------------------
configure_file (${HDF_RESOURCES_DIR}/H5pubconf.h.in ${HDF5_BINARY_DIR}/H5pubconf.h @ONLY)
+#-----------------------------------------------------------------------------
+# Options for use by cross compiling and toolchains
+#-----------------------------------------------------------------------------
+option (HDF5_USE_PREGEN "Use pre-generated Files" OFF)
+option (HDF5_BATCH_H5DETECT "Use a batch command for running h5detect" OFF)
+
include (CMakeInstallation.cmake)