summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2015-10-13 21:16:03 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2015-10-13 21:16:03 (GMT)
commit97f0deef8c1ba1669c6db7fa6a19a119b0b66ddf (patch)
tree5803b242e2a2d6c9b6a2228b1d04bddda74f5ea2 /CMakeLists.txt
parentdd2fe7315c2c9e569b2610e06ac56a164c1f6a2a (diff)
downloadhdf5-97f0deef8c1ba1669c6db7fa6a19a119b0b66ddf.zip
hdf5-97f0deef8c1ba1669c6db7fa6a19a119b0b66ddf.tar.gz
hdf5-97f0deef8c1ba1669c6db7fa6a19a119b0b66ddf.tar.bz2
[svn-r28061] Make UNSUPPORTED option combinations fail configure - matches autotools behaviour.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 3 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 08e65c4..b420459 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -543,24 +543,21 @@ if (WIN32)
endif (HDF5_ENABLE_PARALLEL)
if (HDF5_BUILD_FORTRAN)
if (NOT ALLOW_UNSUPPORTED)
- message (STATUS " **** Fortran and thread-safety options are not supported **** ")
- message (STATUS " **** thread-safety option will not be used building Fortran library **** ")
+ message (FATAL_ERROR " **** Fortran and thread-safety options are not supported **** ")
else (NOT ALLOW_UNSUPPORTED)
message (STATUS " **** Allowing unsupported Fortran and thread-safety options **** ")
endif (NOT ALLOW_UNSUPPORTED)
endif (HDF5_BUILD_FORTRAN)
if (HDF5_BUILD_CPP_LIB)
if (NOT ALLOW_UNSUPPORTED)
- message (STATUS " **** C++ and thread-safety options are not supported **** ")
- message (STATUS " **** thread-safety option will not be used building C++ library **** ")
+ message (FATAL_ERROR " **** C++ and thread-safety options are not supported **** ")
else (NOT ALLOW_UNSUPPORTED)
message (STATUS " **** Allowing unsupported C++ and thread-safety options **** ")
endif (NOT ALLOW_UNSUPPORTED)
endif (HDF5_BUILD_CPP_LIB)
if (HDF5_BUILD_HL_LIB)
if (NOT ALLOW_UNSUPPORTED)
- message (STATUS " **** HL and thread-safety options are not supported **** ")
- message (STATUS " **** thread-safety option will not be used building HL library **** ")
+ message (FATAL_ERROR " **** HL and thread-safety options are not supported **** ")
else (NOT ALLOW_UNSUPPORTED)
message (STATUS " **** Allowing unsupported HL and thread-safety options **** ")
endif (NOT ALLOW_UNSUPPORTED)