summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2011-09-26 14:04:15 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2011-09-26 14:04:15 (GMT)
commita07004c825e3a4e4b61269fd3e5f2b57092f073c (patch)
tree8c4012544251e2d5035c410d22634ba6a5c7d3ab /CMakeLists.txt
parent3c51dc92f4a670be378feed681899bd49c0604e1 (diff)
downloadhdf5-a07004c825e3a4e4b61269fd3e5f2b57092f073c.zip
hdf5-a07004c825e3a4e4b61269fd3e5f2b57092f073c.tar.gz
hdf5-a07004c825e3a4e4b61269fd3e5f2b57092f073c.tar.bz2
[svn-r21418] Change windows default driver to SEC2
Add option to allow -fPIC
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6f2d72f..bfb7ab1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -287,6 +287,17 @@ IF (BUILD_STATIC_EXECS)
ENDIF (BUILD_STATIC_EXECS)
#-----------------------------------------------------------------------------
+# Option to Build Static PIC
+#-----------------------------------------------------------------------------
+OPTION (BUILD_STATIC_PIC "Build Static PIC" OFF)
+IF (BUILD_STATIC_PIC)
+ IF (NOT WIN32)
+ SET (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC")
+ SET (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC")
+ ENDIF (NOT WIN32)
+ENDIF (BUILD_STATIC_PIC)
+
+#-----------------------------------------------------------------------------
# Option to use code coverage
#-----------------------------------------------------------------------------
OPTION (HDF5_ENABLE_COVERAGE "Enable code coverage for Libraries and Programs" OFF)