summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2012-07-13 15:18:27 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2012-07-13 15:18:27 (GMT)
commitd9ba5c234c9971b67f6922ee85cabb638fc0e186 (patch)
tree17b1b5e613731058809663ee0fd00d0a0771106d /CMakeLists.txt
parent5096b7d3ec1047e234049f351b111ef62deb6030 (diff)
downloadhdf5-d9ba5c234c9971b67f6922ee85cabb638fc0e186.zip
hdf5-d9ba5c234c9971b67f6922ee85cabb638fc0e186.tar.gz
hdf5-d9ba5c234c9971b67f6922ee85cabb638fc0e186.tar.bz2
[svn-r22571] HDFFV-7784,-8095,7936 merge from trunk
Tested: local linux with cmake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt31
1 files changed, 29 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3df3dce..47588f1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -962,15 +962,42 @@ IF (NOT HDF5_EXTERNALLY_CONFIGURED AND NOT HDF5_NO_PACKAGES)
SET (CPACK_RESOURCE_FILE_README "${CMAKE_CURRENT_SOURCE_DIR}/release_docs/RELEASE.txt")
ENDIF (EXISTS "${HDF5_SOURCE_DIR}/release_docs")
SET (CPACK_PACKAGE_RELOCATABLE TRUE)
+
IF (WIN32)
SET (CPACK_MONOLITHIC_INSTALL ON)
- SET (CPACK_NSIS_CONTACT "help@hdfgroup.org")
+ SET (CPACK_NSIS_CONTACT "${HDF5_PACKAGE_BUGREPORT}")
SET (CPACK_NSIS_MODIFY_PATH ON)
SET (CPACK_NSIS_PACKAGE_NAME "HDF5 ${HDF5_PACKAGE_VERSION}")
ELSE (WIN32)
- SET (CPACK_RPM_COMPONENT_INSTALL ON)
+ SET (CPACK_PACKAGING_INSTALL_PREFIX "/usr")
SET (CPACK_ARCHIVE_COMPONENT_INSTALL ON)
SET (CPACK_COMPONENTS_ALL_IN_ONE_PACKAGE ON)
+
+ SET (CPACK_DEBIAN_PACKAGE_SECTION "Libraries")
+ SET (CPACK_DEBIAN_PACKAGE_MAINTAINER "${HDF5_PACKAGE_BUGREPORT}")
+
+ SET (CPACK_RPM_COMPONENT_INSTALL ON)
+ SET (CPACK_RPM_PACKAGE_RELOCATABLE ON)
+ SET (CPACK_RPM_PACKAGE_LICENSE "BSD-style")
+ SET (CPACK_RPM_PACKAGE_GROUP "Development/Libraries")
+ SET (CPACK_RPM_PACKAGE_URL "${HDF5_PACKAGE_URL}")
+ SET (CPACK_RPM_PACKAGE_SUMMARY "HDF5 is a unique technology suite that makes possible the management of extremely large and complex data collections.")
+ SET (CPACK_RPM_PACKAGE_DESCRIPTION
+ "The HDF5 technology suite includes:
+
+ * A versatile data model that can represent very complex data objects and a wide variety of metadata.
+
+ * A completely portable file format with no limit on the number or size of data objects in the collection.
+
+ * A software library that runs on a range of computational platforms, from laptops to massively parallel systems, and implements a high-level API with C, C++, Fortran 90, and Java interfaces.
+
+ * A rich set of integrated performance features that allow for access time and storage space optimizations.
+
+ * Tools and applications for managing, manipulating, viewing, and analyzing the data in the collection.
+
+The HDF5 data model, file format, API, library, and tools are open and distributed without charge.
+"
+ )
ENDIF (WIN32)
INCLUDE(InstallRequiredSystemLibraries)