summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2013-09-26 22:10:54 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2013-09-26 22:10:54 (GMT)
commitdeddc7f9558d76a4cebc417af8d426877d5aee7d (patch)
treee2e43dea685c798debbbe6ae14f7297738c0bfbd /CMakeLists.txt
parente2dfb53df72ca884cb9225e738aef77135f92e68 (diff)
downloadhdf5-deddc7f9558d76a4cebc417af8d426877d5aee7d.zip
hdf5-deddc7f9558d76a4cebc417af8d426877d5aee7d.tar.gz
hdf5-deddc7f9558d76a4cebc417af8d426877d5aee7d.tar.bz2
[svn-r24205] Merge HDFFV-8513/8522 from trunk (via cmake branch), h5repack UD plugins.
Also warning session fixes. Tested: CMake local linux
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index db4b3d4..6f60b0f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -467,6 +467,7 @@ ENDIF (HDF5_DISABLE_COMPILER_WARNINGS)
# break into groups (from the config/gnu-flags file)
#-----------------------------------------------------------------------------
IF (NOT MSVC)
+ SET (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -W -Wundef -Wshadow -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wwrite-strings -Wconversion -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls -Wnested-externs -Winline")
# Append warning flags
# Don't use the '-Wtraditional' flag, we're way past having K&R C code
# SET (H5_CFLAGS "${H5_CFLAGS} -Wtraditional")