summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2011-04-20 17:32:12 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2011-04-20 17:32:12 (GMT)
commit15231113cb5816fa755304665a48b7aa0390eaac (patch)
tree11c15cf4141fefa792074a56211817252e50bc40 /CMakeLists.txt
parent23e2eff7a3c0f66b3a9952560cc9a823e431610a (diff)
downloadhdf5-15231113cb5816fa755304665a48b7aa0390eaac.zip
hdf5-15231113cb5816fa755304665a48b7aa0390eaac.tar.gz
hdf5-15231113cb5816fa755304665a48b7aa0390eaac.tar.bz2
[svn-r20568] Bug #5929: On windows check for existence of InitOnceExecuteOnce for use by threads.
Tested: Windows Xp and 7
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a9bce2c..8d1e026 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -610,8 +610,10 @@ IF (WIN32 AND NOT CYGWIN)
MESSAGE (FATAL " **** Parallel and Threadsafe options are mutually exclusive **** ")
ENDIF (HDF5_ENABLE_PARALLEL)
SET (H5_HAVE_THREADSAFE 1)
- SET (H5_HAVE_WIN_THREADS 1)
- MESSAGE (STATUS " **** Windows Threads only available in WINVER>=0x600 (Vista or Windows 7)**** ")
+ IF (H5_HAVE_IOEO)
+ MESSAGE (STATUS " **** Windows Threads only available in WINVER>=0x600 (Vista or Windows 7)**** ")
+ SET (H5_HAVE_WIN_THREADS 1)
+ ENDIF (H5_HAVE_IOEO)
ENDIF (HDF5_ENABLE_THREADSAFE)
ENDIF (WIN32 AND NOT CYGWIN)