summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2011-10-06 19:26:06 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2011-10-06 19:26:06 (GMT)
commit23ecc115b8940afc8406313fd5ba16ee9bdbe52c (patch)
tree894ce95e06a735344f8955d8b7d05c09241361c7 /CMakeLists.txt
parentd3b7ce468989bea9ef4e8f78e53b52b2ae766da3 (diff)
downloadhdf5-23ecc115b8940afc8406313fd5ba16ee9bdbe52c.zip
hdf5-23ecc115b8940afc8406313fd5ba16ee9bdbe52c.tar.gz
hdf5-23ecc115b8940afc8406313fd5ba16ee9bdbe52c.tar.bz2
[svn-r21482] Add option to enable windows stdio
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ff63012..17e655c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -256,6 +256,16 @@ IF (WIN32 AND NOT CYGWIN)
ENDIF (WIN32 AND NOT CYGWIN)
#-----------------------------------------------------------------------------
+# Option to enable use of stdio instead of posix io
+#-----------------------------------------------------------------------------
+IF (WIN32)
+ OPTION (HDF5_ENABLE_WINDOWS_STDIO "Enable use of stdio instead of posix io" OFF)
+ IF (HDF5_ENABLE_WINDOWS_STDIO)
+ SET (H5_WINDOWS_USE_STDIO 1)
+ ENDIF (HDF5_ENABLE_WINDOWS_STDIO)
+ENDIF (WIN32)
+
+#-----------------------------------------------------------------------------
# Option to Build Shared/Static libs, default is static
#-----------------------------------------------------------------------------
OPTION (BUILD_SHARED_LIBS "Build Shared Libraries" OFF)