summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2010-09-10 16:15:57 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2010-09-10 16:15:57 (GMT)
commit2d9a70085c38816df68a1b2cfce59c05853e3c4a (patch)
tree4fd2b91f1dcf8291ab6654caa8a68eef46aff824 /CMakeLists.txt
parenta8646632e8f76b729c141d0570700bae2fa884e9 (diff)
downloadhdf5-2d9a70085c38816df68a1b2cfce59c05853e3c4a.zip
hdf5-2d9a70085c38816df68a1b2cfce59c05853e3c4a.tar.gz
hdf5-2d9a70085c38816df68a1b2cfce59c05853e3c4a.tar.bz2
[svn-r19368] Purpose:
Add windows threads support to HDF5. Description: Added calls to the windows threads library to the H5TS layer, and wrapped most calls to either pthreads or windows threads library with portable H5TS-style defines. Modified tests to use portable function definitions as well. This can be configured via CMake with the HDF5_ENABLE_THREADSAFE option, and should work on windows vista and later operating systems. Tested: h5committest, plus threadsafe with pthreads on jam and amani, and tested on a Windows Vista VM with threadsafe using windows threads.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7435c50..ac143f4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -520,6 +520,18 @@ IF (WIN32)
ENDIF (WIN32)
#-----------------------------------------------------------------------------
+# Option to use threadsafe
+# Note: Currently CMake only allows configuring of threadsafe on WINDOWS.
+#-----------------------------------------------------------------------------
+IF (WIN32)
+OPTION (HDF5_ENABLE_THREADSAFE "Enable Threadsafety" OFF)
+IF (HDF5_ENABLE_THREADSAFE)
+ SET (H5_HAVE_WIN_THREADS 1)
+ SET (H5_HAVE_THREADSAFE 1)
+ENDIF (HDF5_ENABLE_THREADSAFE)
+ENDIF (WIN32)
+
+#-----------------------------------------------------------------------------
# Option to use PACKED BITS SUPPORT
#-----------------------------------------------------------------------------
OPTION (HDF5_USE_H5DUMP_PACKED_BITS "Use the PACKED BITS feature in h5dump" OFF)