summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2014-04-22 19:02:40 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2014-04-22 19:02:40 (GMT)
commit2fc0c50a9dee7aaf810c210068e702d54ec7a3b2 (patch)
tree9ed7b8b24274e2cf919c2478861c0faad43ee3a8 /CMakeLists.txt
parent3bd99b85badc4bdfc7452d90dfab941a994da29b (diff)
downloadhdf5-2fc0c50a9dee7aaf810c210068e702d54ec7a3b2.zip
hdf5-2fc0c50a9dee7aaf810c210068e702d54ec7a3b2.tar.gz
hdf5-2fc0c50a9dee7aaf810c210068e702d54ec7a3b2.tar.bz2
[svn-r25076] Correct the install folder logic.
Tested: local linux
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 2 insertions, 18 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2cf05cd..a82dcfa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -213,22 +213,6 @@ set (HDF5_PACKAGE_URL "http://www.hdfgroup.org")
set (HDF5_PACKAGE_BUGREPORT "help@hdfgroup.org")
#-----------------------------------------------------------------------------
-# Set Install folder value
-#-----------------------------------------------------------------------------
-if (CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
- if (CMAKE_HOST_UNIX)
- set (CMAKE_INSTALL_PREFIX "/HDF_Group/${HDF5_PACKAGE_NAME}/${HDF5_PACKAGE_VERSION}"
- CACHE PATH "Install path prefix, prepended onto install directories." FORCE)
- else (CMAKE_HOST_UNIX)
- GetDefaultWindowsPrefixBase(CMAKE_GENERIC_PROGRAM_FILES)
- set (CMAKE_INSTALL_PREFIX
- "${CMAKE_GENERIC_PROGRAM_FILES}/HDF_Group/${HDF5_PACKAGE_NAME}/${HDF5_PACKAGE_VERSION}"
- CACHE PATH "Install path prefix, prepended onto install directories." FORCE)
- set (CMAKE_GENERIC_PROGRAM_FILES)
- endif (CMAKE_HOST_UNIX)
-endif (CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
-
-#-----------------------------------------------------------------------------
# Include some macros for reusable code
#-----------------------------------------------------------------------------
include (${HDF5_RESOURCES_DIR}/HDFMacros.cmake)
@@ -716,7 +700,7 @@ endif (NOT HDF5_EXTERNALLY_CONFIGURED)
# Note: Currently CMake only allows configuring of threadsafe on
# non-Cygwin WINDOWS.
#-----------------------------------------------------------------------------
-if (WIN32 AND NOT CYGWIN)
+if (WIN32)
option (HDF5_ENABLE_THREADSAFE "Enable thread-safety" OFF)
if (HDF5_ENABLE_THREADSAFE)
# check for unsupported options
@@ -743,7 +727,7 @@ if (WIN32 AND NOT CYGWIN)
endif (NOT H5_HAVE_PTHREAD_H)
endif (H5_HAVE_IOEO)
endif (HDF5_ENABLE_THREADSAFE)
-endif (WIN32 AND NOT CYGWIN)
+endif (WIN32)
#-----------------------------------------------------------------------------
# Add the HDF5 Library Target to the build