summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-06-22 19:09:46 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-06-22 19:09:46 (GMT)
commit464fe0dcfe83ea23e2e17178cf309224daf41c6c (patch)
tree3f732bb8dbc911d3a47ec3f0ec67ef0f314fdb9d /CMakeLists.txt
parentd48508fb8ccf1784056045acb1c483a3c9b7f846 (diff)
downloadhdf5-464fe0dcfe83ea23e2e17178cf309224daf41c6c.zip
hdf5-464fe0dcfe83ea23e2e17178cf309224daf41c6c.tar.gz
hdf5-464fe0dcfe83ea23e2e17178cf309224daf41c6c.tar.bz2
[svn-r19029] added new cmake files for testing
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1a7ebf2..8576b41 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -233,8 +233,8 @@ ENDIF (BUILD_SHARED_LIBS)
#-----------------------------------------------------------------------------
OPTION (HDF5_ENABLE_COVERAGE "Enable code coverage for Libraries and Programs" OFF)
IF (HDF5_ENABLE_COVERAGE)
- SET (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fprofile-arcs -ftest-coverage")
- SET (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fprofile-arcs -ftest-coverage")
+ SET (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -g -O0 -fprofile-arcs -ftest-coverage")
+ SET (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g -O0 -fprofile-arcs -ftest-coverage")
SET (LDFLAGS "${LDFLAGS} -fprofile-arcs -ftest-coverage")
ENDIF (HDF5_ENABLE_COVERAGE)