summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2011-04-11 20:55:09 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2011-04-11 20:55:09 (GMT)
commit46c8a9f06fb4bc700a6a5c73bc569369a58a6bf5 (patch)
tree69ff4c82129dd10e5c7af20c4348968bee073826 /CMakeLists.txt
parent57e65197486beffc8aeb1c32e132bc4136990eab (diff)
downloadhdf5-46c8a9f06fb4bc700a6a5c73bc569369a58a6bf5.zip
hdf5-46c8a9f06fb4bc700a6a5c73bc569369a58a6bf5.tar.gz
hdf5-46c8a9f06fb4bc700a6a5c73bc569369a58a6bf5.tar.bz2
[svn-r20473] Add message that H5_HAVE_WIN_THREADS requires WINVER >= 0x600 (VISTA or WIN7)
Bring r20472 from trunk
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 77c48f3..a9bce2c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -609,8 +609,9 @@ IF (WIN32 AND NOT CYGWIN)
IF (HDF5_ENABLE_PARALLEL)
MESSAGE (FATAL " **** Parallel and Threadsafe options are mutually exclusive **** ")
ENDIF (HDF5_ENABLE_PARALLEL)
- SET (H5_HAVE_WIN_THREADS 1)
SET (H5_HAVE_THREADSAFE 1)
+ SET (H5_HAVE_WIN_THREADS 1)
+ MESSAGE (STATUS " **** Windows Threads only available in WINVER>=0x600 (Vista or Windows 7)**** ")
ENDIF (HDF5_ENABLE_THREADSAFE)
ENDIF (WIN32 AND NOT CYGWIN)