summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-12-02 14:32:12 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-12-02 14:32:12 (GMT)
commit5606cd6f9b7a630c902d5b76715ef6d741413c47 (patch)
tree413116b63d856919ed0388c4fc78462cca78c697 /CMakeLists.txt
parente58706fc3bb5fc53ada8e2cdde02f4b317ac867b (diff)
downloadhdf5-5606cd6f9b7a630c902d5b76715ef6d741413c47.zip
hdf5-5606cd6f9b7a630c902d5b76715ef6d741413c47.tar.gz
hdf5-5606cd6f9b7a630c902d5b76715ef6d741413c47.tar.bz2
[svn-r19866] Correct INSTALL_PREFIX handling
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b5710fa..a3aa00c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -133,7 +133,9 @@ SET (HDF5_PERFORM_SRC_DIR ${HDF5_SOURCE_DIR}/perform)
SET (HDF5_F90_SRC_DIR ${HDF5_SOURCE_DIR}/fortran)
# set default prefix location
-SET (CMAKE_INSTALL_PREFIX "./hdf5" CACHE PATH "Install path prefix, prepended onto install directories")
+IF(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
+ SET(CMAKE_INSTALL_PREFIX "hdf5" CACHE PATH "Install path prefix, prepended onto install directories" FORCE)
+ENDIF(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
IF (NOT HDF5_INSTALL_BIN_DIR)
SET (HDF5_INSTALL_BIN_DIR bin)