summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-11-27 18:40:08 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-11-27 18:40:08 (GMT)
commit6eec7b5d3621a40bafae0a7b853a301912a33286 (patch)
treeb43a60e352fa36ec1344941cf78274e4a71b34fe /CMakeLists.txt
parentd0e501bd07ca424fd4553b3b6afd2df6c29e98b0 (diff)
downloadhdf5-6eec7b5d3621a40bafae0a7b853a301912a33286.zip
hdf5-6eec7b5d3621a40bafae0a7b853a301912a33286.tar.gz
hdf5-6eec7b5d3621a40bafae0a7b853a301912a33286.tar.bz2
[svn-r19855] Correct external library generated headers packing for install/cpack when not using svn builds
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 709d06c..ee7a213 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -484,6 +484,7 @@ IF (HDF5_ENABLE_Z_LIB_SUPPORT)
SET (H5_HAVE_ZLIB_H 1)
SET (H5_HAVE_LIBZ 1)
SET (H5_ZLIB_HEADER "zlib.h")
+ SET (ZLIB_INCLUDE_DIR_GEN ${ZLIB_INCLUDE_DIR})
ELSE (ZLIB_FOUND)
IF (HDF5_ALLOW_EXTERNAL_SUPPORT MATCHES "SVN")
EXTERNALPROJECT_ADD (ZLIB
@@ -560,6 +561,7 @@ IF (HDF5_ENABLE_SZIP_SUPPORT)
SET (H5_HAVE_FILTER_SZIP 1)
SET (H5_HAVE_SZLIB_H 1)
SET (H5_HAVE_LIBSZ 1)
+ SET (SZIP_INCLUDE_DIR_GEN ${SZIP_INCLUDE_DIR})
ELSE (SZIP_FOUND)
IF (HDF5_ALLOW_EXTERNAL_SUPPORT MATCHES "SVN")
EXTERNALPROJECT_ADD (SZIP