summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-05-28 21:25:17 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-05-28 21:25:17 (GMT)
commit8bfe9e54bd23add27076290f59bdc09c3d3ee2bb (patch)
tree2d1546aa21f4e3be15e615fe5178834cf0f160fc /CMakeLists.txt
parent0844b48690d92783907b72e8504b432ad6d0b7c0 (diff)
downloadhdf5-8bfe9e54bd23add27076290f59bdc09c3d3ee2bb.zip
hdf5-8bfe9e54bd23add27076290f59bdc09c3d3ee2bb.tar.gz
hdf5-8bfe9e54bd23add27076290f59bdc09c3d3ee2bb.tar.bz2
[svn-r18924] Updated install of fortran mod files
Tested: local linux
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 5 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2efdfbe..30f9ece 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -569,14 +569,6 @@ INSTALL (
HDF5-config.cmake
)
-# The install rule below copies compiled module files to the install location
-# using a "code" rule. The code string should not be broken up, it must be on one line
-IF (HDF5_BUILD_FORTRAN)
- INSTALL ( CODE
- "EXECUTE_PROCESS (COMMAND \"${CMAKE_COMMAND}\" -E copy_directory \"${CMAKE_Fortran_MODULE_DIRECTORY}/\${BUILD_TYPE}\" \"${CMAKE_INSTALL_PREFIX}/fortran\")"
- )
-ENDIF (HDF5_BUILD_FORTRAN)
-
#-----------------------------------------------------------------------------
# Export all exported targets to the build tree for use by parent project
#-----------------------------------------------------------------------------
@@ -628,6 +620,11 @@ IF (HDF5_BUILD_FORTRAN)
DEPENDS libraries
GROUP Runtime
)
+ CPACK_ADD_COMPONENT (fortheaders
+ DISPLAY_NAME "HDF5 Fortran Headers"
+ DEPENDS fortlibraries
+ GROUP Development
+ )
ENDIF (HDF5_BUILD_FORTRAN)
IF (HDF5_BUILD_CPP_LIB)