summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2011-10-12 21:25:51 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2011-10-12 21:25:51 (GMT)
commitb80f663629f73a8cd3fc46fd58b06c8bf4c528d7 (patch)
tree5166d84e980d08195adb525dd5b96bc3e67adc4e /CMakeLists.txt
parent3aa1b1d93cad549d092eba87826d207a5f04051b (diff)
downloadhdf5-b80f663629f73a8cd3fc46fd58b06c8bf4c528d7.zip
hdf5-b80f663629f73a8cd3fc46fd58b06c8bf4c528d7.tar.gz
hdf5-b80f663629f73a8cd3fc46fd58b06c8bf4c528d7.tar.bz2
[svn-r21531] Merge of 21501 and 21502 from trunk:
Note that this differs slightly from the trunk code since the VFL API won't be changed until 1.10. In the 1.8 branch, the term() function is public and this required some #defines for the Windows VFD. 21501: - Propagated Windows VFD tweaks to SEC2 and log VFDs. - Created typedefs and #defines to make POSIX I/O type-safe on Windows and true POSIX platforms. - Added pre-checks and removed post-checks for POSIX I/O sizes. When the number of bytes to be sent exceeds the maximum return value, the operation is split into smaller subsets. - General code tidying and cleanup. 21502: - Removed Windows VFD code. H5Pset_fapl_windows() actually sets the SEC2 driver, though it will still report H5FD_WINDOWS.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 0 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 17e655c..ff63012 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -256,16 +256,6 @@ IF (WIN32 AND NOT CYGWIN)
ENDIF (WIN32 AND NOT CYGWIN)
#-----------------------------------------------------------------------------
-# Option to enable use of stdio instead of posix io
-#-----------------------------------------------------------------------------
-IF (WIN32)
- OPTION (HDF5_ENABLE_WINDOWS_STDIO "Enable use of stdio instead of posix io" OFF)
- IF (HDF5_ENABLE_WINDOWS_STDIO)
- SET (H5_WINDOWS_USE_STDIO 1)
- ENDIF (HDF5_ENABLE_WINDOWS_STDIO)
-ENDIF (WIN32)
-
-#-----------------------------------------------------------------------------
# Option to Build Shared/Static libs, default is static
#-----------------------------------------------------------------------------
OPTION (BUILD_SHARED_LIBS "Build Shared Libraries" OFF)