summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2015-10-13 20:58:20 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2015-10-13 20:58:20 (GMT)
commitdd2fe7315c2c9e569b2610e06ac56a164c1f6a2a (patch)
treed92b00d47ba102a779fe1b9b45a22b8ab549ca14 /CMakeLists.txt
parentfaf35f2d4c9a74eed3e9b34f5b9b334870ee8783 (diff)
downloadhdf5-dd2fe7315c2c9e569b2610e06ac56a164c1f6a2a.zip
hdf5-dd2fe7315c2c9e569b2610e06ac56a164c1f6a2a.tar.gz
hdf5-dd2fe7315c2c9e569b2610e06ac56a164c1f6a2a.tar.bz2
[svn-r28058] Add HL and Threadsafe notice
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0e98bba..08e65c4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -557,6 +557,14 @@ if (WIN32)
message (STATUS " **** Allowing unsupported C++ and thread-safety options **** ")
endif (NOT ALLOW_UNSUPPORTED)
endif (HDF5_BUILD_CPP_LIB)
+ if (HDF5_BUILD_HL_LIB)
+ if (NOT ALLOW_UNSUPPORTED)
+ message (STATUS " **** HL and thread-safety options are not supported **** ")
+ message (STATUS " **** thread-safety option will not be used building HL library **** ")
+ else (NOT ALLOW_UNSUPPORTED)
+ message (STATUS " **** Allowing unsupported HL and thread-safety options **** ")
+ endif (NOT ALLOW_UNSUPPORTED)
+ endif (HDF5_BUILD_HL_LIB)
if (H5_HAVE_IOEO)
message (STATUS " **** Win32 threads requires WINVER>=0x600 (Windows Vista/7/8) **** ")
set (H5_HAVE_WIN_THREADS 1)