summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2023-03-18 04:21:31 (GMT)
committerGitHub <noreply@github.com>2023-03-18 04:21:31 (GMT)
commitebdbd503ca1d1a50701937542c6a9e66a3885458 (patch)
tree622a3fefca8af417c946ae5e2447fee95c374fbe /CMakeLists.txt
parenta01f570f97287295e960633feab4c3908ea318d7 (diff)
downloadhdf5-ebdbd503ca1d1a50701937542c6a9e66a3885458.zip
hdf5-ebdbd503ca1d1a50701937542c6a9e66a3885458.tar.gz
hdf5-ebdbd503ca1d1a50701937542c6a9e66a3885458.tar.bz2
Allow parallel thread-safe builds (#2584)
* Allow parallel + thread-safe builds No longer require the "enable unsupported" option to build this configuration in CMake and the Autotools. * Add a release note for parallel thread-safety
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3230a29..eee74cc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -821,15 +821,6 @@ if (HDF5_ENABLE_THREADSAFE)
message (VERBOSE " **** thread-safety option will not be used building static library **** ")
endif ()
endif ()
- if (HDF5_ENABLE_PARALLEL)
- if (NOT ALLOW_UNSUPPORTED)
- message (FATAL_ERROR " **** parallel and thread-safety options are not supported, override with ALLOW_UNSUPPORTED option **** ")
- else ()
- if (CMAKE_VERSION VERSION_GREATER_EQUAL "3.15.0")
- message (VERBOSE " **** Allowing unsupported parallel and thread-safety options **** ")
- endif ()
- endif ()
- endif ()
if (HDF5_BUILD_FORTRAN)
if (NOT ALLOW_UNSUPPORTED)
message (FATAL_ERROR " **** Fortran and thread-safety options are not supported, override with ALLOW_UNSUPPORTED option **** ")