summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2019-02-06 16:47:11 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2019-02-06 16:47:11 (GMT)
commitfef7d6b0fc387cf793c9a7be1115de82155c2d5e (patch)
tree8d8b146af144792fbb5d60d92ad23e96bfb85dd8 /CMakeLists.txt
parente9541010eecf7915e0c2de0365a3909516bab65d (diff)
downloadhdf5-fef7d6b0fc387cf793c9a7be1115de82155c2d5e.zip
hdf5-fef7d6b0fc387cf793c9a7be1115de82155c2d5e.tar.gz
hdf5-fef7d6b0fc387cf793c9a7be1115de82155c2d5e.tar.bz2
Cleanup F2003 option for CMake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 2 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7b1a3ba..81d81b6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -818,9 +818,6 @@ set (H5_FC_FUNC_ "H5_FC_FUNC_(name,NAME) name ## _")
if (EXISTS "${HDF5_SOURCE_DIR}/fortran" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/fortran")
option (HDF5_BUILD_FORTRAN "Build FORTRAN support" OFF)
if (HDF5_BUILD_FORTRAN)
-
- option (HDF5_ENABLE_F2003 "Enable FORTRAN 2003 Standard" ON)
-
include (${HDF_RESOURCES_EXT_DIR}/HDFUseFortran.cmake)
message (STATUS "Fortran compiler ID is ${CMAKE_Fortran_COMPILER_ID}")
@@ -833,10 +830,8 @@ if (EXISTS "${HDF5_SOURCE_DIR}/fortran" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/for
include (${HDF_RESOURCES_DIR}/HDF5UseFortran.cmake)
set (LINK_Fortran_LIBS ${LINK_LIBS})
- if (HDF5_ENABLE_F2003)
- if (NOT FORTRAN_HAVE_ISO_C_BINDING)
- set (HDF5_ENABLE_F2003 OFF)
- endif ()
+ if (NOT FORTRAN_HAVE_ISO_C_BINDING)
+ message (FATAL_ERROR " **** Fortran compiler lacks required Fortran 2003 features; unsupported Fortran 2003 compiler, disable HDF5_BUILD_FORTRAN **** ")
endif ()
# Parallel IO usage requires MPI to be Linked and Included