summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2022-04-29 03:46:21 (GMT)
committerGitHub <noreply@github.com>2022-04-29 03:46:21 (GMT)
commit02a5508e50073cd533a150ac923b028d1d7af013 (patch)
treeb041096a07e1b5ddf225f472226932ffb376b7bc /CMakeLists.txt
parent44a803aefb8a2f1177733664dfd3f41823ec3286 (diff)
downloadhdf5-02a5508e50073cd533a150ac923b028d1d7af013.zip
hdf5-02a5508e50073cd533a150ac923b028d1d7af013.tar.gz
hdf5-02a5508e50073cd533a150ac923b028d1d7af013.tar.bz2
Reinstate java API removed in 1.10.8 (#1697)
* Revert java API removal with JNI private function * Fix name typo * Correct format
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 71ab918..f5c9876 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,10 +2,13 @@ cmake_minimum_required (VERSION 3.12)
project (HDF5 C)
if (POLICY CMP0074)
+ # find_package() uses <PackageName>_ROOT variables.
cmake_policy (SET CMP0074 NEW)
endif ()
if (POLICY CMP0083)
+ # To control generation of Position Independent Executable (PIE) or not,
+ # some flags are required at link time.
cmake_policy (SET CMP0083 NEW)
endif ()