summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-09-26 21:04:34 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-09-26 21:04:34 (GMT)
commit8f103a935be942a4240da9e57a0f67504588948a (patch)
tree130b0379ef8b355fd4555225f182727773aed084 /CMakeLists.txt
parent873249b58bcf62d73f830d7d9ee056cd554f370d (diff)
downloadhdf5-8f103a935be942a4240da9e57a0f67504588948a.zip
hdf5-8f103a935be942a4240da9e57a0f67504588948a.tar.gz
hdf5-8f103a935be942a4240da9e57a0f67504588948a.tar.bz2
HDFFV-10594, 10332, 10531
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8a0a039..24bb83d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -46,6 +46,9 @@ endif ()
# dependencies of the HDF5 libs may be 'incomplete', add additional
# dependencies to this variable so that external projects pick them up
#
+#option (HDF5_EXTERNAL_LIB_PREFIX "Use prefix for custom library naming." "")
+set (HDF5_EXTERNAL_LIB_PREFIX "" CACHE STRING "Use prefix for custom library naming.")
+mark_as_advanced (HDF5_EXTERNAL_LIB_PREFIX)
# HDF5_EXTERNAL_LIB_PREFIX :
# If the parent project needs to install hdf libraries, but avoid
# name conflicts with system versions, then a prefix may be added