summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2020-12-15 23:11:11 (GMT)
committerGitHub <noreply@github.com>2020-12-15 23:11:11 (GMT)
commita2888c8df1de86eb94a898a5d5ff6a27a84f8301 (patch)
tree22b337e5e6f3cf9586c2527302e86963cd3cca22 /CMakeLists.txt
parent2acfa58d892feb6e1155625744593aafe2ea7315 (diff)
downloadhdf5-a2888c8df1de86eb94a898a5d5ff6a27a84f8301.zip
hdf5-a2888c8df1de86eb94a898a5d5ff6a27a84f8301.tar.gz
hdf5-a2888c8df1de86eb94a898a5d5ff6a27a84f8301.tar.bz2
OESS-98 fix tools test for plugins (#179)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt30
1 files changed, 15 insertions, 15 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 135e1ba..10812cb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -915,21 +915,6 @@ if (BUILD_TESTING)
endif ()
#-----------------------------------------------------------------------------
-# Include filter plugins
-#-----------------------------------------------------------------------------
-include (CMakePlugins.cmake)
-
-if (HDF5_PACKAGE_EXTLIBS AND NOT HDF5_NO_PACKAGES)
- if (HDF5_ENABLE_PLUGIN_SUPPORT AND PLUGIN_FOUND)
- PACKAGE_PLUGIN_LIBRARY (${HDF5_ALLOW_EXTERNAL_SUPPORT})
-# option (HDF5_TEST_PLUGIN "Execute plugin tests" ON)
-# mark_as_advanced (HDF5_TEST_PLUGIN)
-
-# TEST_PLUGIN_LIBRARY ()
- endif ()
-endif ()
-
-#-----------------------------------------------------------------------------
# Option to build HDF5 Utilities
#-----------------------------------------------------------------------------
if (EXISTS "${HDF5_SOURCE_DIR}/utils" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/utils")
@@ -950,6 +935,21 @@ if (EXISTS "${HDF5_SOURCE_DIR}/tools" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/tools
endif ()
#-----------------------------------------------------------------------------
+# Include filter plugins
+#-----------------------------------------------------------------------------
+include (CMakePlugins.cmake)
+
+if (HDF5_PACKAGE_EXTLIBS AND NOT HDF5_NO_PACKAGES)
+ if (HDF5_ENABLE_PLUGIN_SUPPORT AND PLUGIN_FOUND)
+ PACKAGE_PLUGIN_LIBRARY (${HDF5_ALLOW_EXTERNAL_SUPPORT})
+# option (HDF5_TEST_PLUGIN "Execute plugin tests" ON)
+# mark_as_advanced (HDF5_TEST_PLUGIN)
+
+# TEST_PLUGIN_LIBRARY ()
+ endif ()
+endif ()
+
+#-----------------------------------------------------------------------------
# Option to build examples
#-----------------------------------------------------------------------------
if (EXISTS "${HDF5_SOURCE_DIR}/examples" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/examples")