summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-10-23 16:00:36 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-10-23 16:00:36 (GMT)
commitb6e61e8310a1e0a14de6f427b853716d447af373 (patch)
treea3027959709ea591619ca067776c64f02a563c06 /CMakeLists.txt
parentea2a969ce2a3a7dea80fcb2e5798da9307f04937 (diff)
downloadhdf5-b6e61e8310a1e0a14de6f427b853716d447af373.zip
hdf5-b6e61e8310a1e0a14de6f427b853716d447af373.tar.gz
hdf5-b6e61e8310a1e0a14de6f427b853716d447af373.tar.bz2
Merge CMake changes from develop
Improved cross-compiling and toolchains
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 24bb83d..f1603f0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -903,4 +903,10 @@ endif ()
#-----------------------------------------------------------------------------
configure_file (${HDF_RESOURCES_DIR}/H5pubconf.h.in ${HDF5_BINARY_DIR}/H5pubconf.h @ONLY)
+#-----------------------------------------------------------------------------
+# Options for use by cross compiling and toolchains
+#-----------------------------------------------------------------------------
+option (HDF5_USE_PREGEN "Use pre-generated Files" OFF)
+option (HDF5_BATCH_H5DETECT "Use a batch command for running h5detect" OFF)
+
include (CMakeInstallation.cmake)