summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2022-05-20 17:07:09 (GMT)
committerGitHub <noreply@github.com>2022-05-20 17:07:09 (GMT)
commit4466a30825eda620a00e5d8fac35ecf765296aad (patch)
tree84497284f2a6c6558a02329512f379328fdbdfa9 /CMakeLists.txt
parent60820abcbef0cd4efa23cabacc728c088aebf554 (diff)
downloadhdf5-4466a30825eda620a00e5d8fac35ecf765296aad.zip
hdf5-4466a30825eda620a00e5d8fac35ecf765296aad.tar.gz
hdf5-4466a30825eda620a00e5d8fac35ecf765296aad.tar.bz2
Change TestExpress #1722 (#1776)
* Change TestExpress #1722 * Update comment
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index eed592d..18b7b87 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -951,8 +951,13 @@ if (BUILD_TESTING)
mark_as_advanced (HDF5_TEST_FHEAP_PASSTHROUGH VOL)
endif ()
- option (HDF_TEST_EXPRESS "Control testing framework (0-3)" "0")
+ set (H5_TEST_EXPRESS_LEVEL_DEFAULT "3")
+ set (HDF_TEST_EXPRESS "${H5_TEST_EXPRESS_LEVEL_DEFAULT}"
+ CACHE STRING "Control testing framework (0-3) (0 = exhaustive testing; 3 = quicker testing)")
mark_as_advanced (HDF_TEST_EXPRESS)
+ if (NOT "${HDF_TEST_EXPRESS}" STREQUAL "")
+ set (H5_TEST_EXPRESS_LEVEL_DEFAULT "${HDF_TEST_EXPRESS}")
+ endif ()
enable_testing ()
include (CTest)