summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-02-23 22:21:35 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2020-02-23 22:21:35 (GMT)
commit5b5ff6ee094033f2ecd974b8e0bdaac2b0c7e617 (patch)
tree9a66c1ca7d41eacedd83607a3b8dc45d0bff2ef7 /CMakeLists.txt
parent9ed096fb39e2e1851ed27f292a97baa45f306d01 (diff)
downloadhdf5-5b5ff6ee094033f2ecd974b8e0bdaac2b0c7e617.zip
hdf5-5b5ff6ee094033f2ecd974b8e0bdaac2b0c7e617.tar.gz
hdf5-5b5ff6ee094033f2ecd974b8e0bdaac2b0c7e617.tar.bz2
Correct usage of add_compile_definitions
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b10eb8d..ff7af8f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -564,9 +564,7 @@ endif ()
set (EXE_EXT "")
if (WIN32 OR MINGW)
set (EXE_EXT ".exe")
- add_compile_definitions (-D_BIND_TO_CURRENT_VCLIBS_VERSION=1)
- add_compile_definitions (-D_CRT_SECURE_NO_WARNINGS)
- add_compile_definitions (-D_CONSOLE)
+ add_compile_definitions (_BIND_TO_CURRENT_VCLIBS_VERSION=1 _CRT_SECURE_NO_WARNINGS _CONSOLE)
endif ()
if (MSVC)