summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-10-16 16:09:02 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2020-10-16 16:09:02 (GMT)
commit72f5f74b67f72364b9c5b23e9d0c3ad69b1eb19b (patch)
tree8a9153cb16930982a2d56bb7f0918fb1b89e583d /CMakeLists.txt
parentee5662650911ef3eded80ccc6c1748e74e045353 (diff)
downloadhdf5-72f5f74b67f72364b9c5b23e9d0c3ad69b1eb19b.zip
hdf5-72f5f74b67f72364b9c5b23e9d0c3ad69b1eb19b.tar.gz
hdf5-72f5f74b67f72364b9c5b23e9d0c3ad69b1eb19b.tar.bz2
OESS-98 add CMake option to build plugins project within hdf5
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 18 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b48fdd5..704e89a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -409,6 +409,7 @@ include (${HDF_RESOURCES_EXT_DIR}/HDFMacros.cmake)
HDF_DIR_PATHS(${HDF5_PACKAGE_NAME})
include (${HDF_RESOURCES_EXT_DIR}/HDFLibMacros.cmake)
+include (${HDF_RESOURCES_DIR}/HDF5PluginMacros.cmake)
include (${HDF_RESOURCES_DIR}/HDF5Macros.cmake)
#-----------------------------------------------------------------------------
@@ -825,6 +826,17 @@ endif ()
#-----------------------------------------------------------------------------
add_subdirectory (src)
+#-----------------------------------------------------------------------------
+# Include filter plugins
+#-----------------------------------------------------------------------------
+include (CMakePlugins.cmake)
+
+if (HDF5_PACKAGE_EXTLIBS AND NOT HDF5_NO_PACKAGES)
+ if (HDF5_ENABLE_PLUGIN_SUPPORT AND PLUGIN_FOUND)
+ PACKAGE_PLUGIN_LIBRARY (${HDF5_ALLOW_EXTERNAL_SUPPORT})
+ endif ()
+endif ()
+
if (HDF5_ALLOW_EXTERNAL_SUPPORT MATCHES "GIT" OR HDF5_ALLOW_EXTERNAL_SUPPORT MATCHES "TGZ")
if (ZLIB_FOUND AND ZLIB_USE_EXTERNAL)
if (NOT ONLY_SHARED_LIBS)
@@ -842,6 +854,11 @@ if (HDF5_ALLOW_EXTERNAL_SUPPORT MATCHES "GIT" OR HDF5_ALLOW_EXTERNAL_SUPPORT MAT
add_dependencies (${HDF5_LIBSH_TARGET} SZIP)
endif ()
endif ()
+ if (PLUGIN_FOUND AND PLUGIN_USE_EXTERNAL)
+ if (BUILD_SHARED_LIBS)
+ add_dependencies (PLUGIN ${HDF5_LIBSH_TARGET})
+ endif ()
+ endif ()
endif ()
#-----------------------------------------------------------------------------
@@ -1064,7 +1081,7 @@ endif ()
#-----------------------------------------------------------------------------
# Generate the H5pubconf.h file containing user settings needed by compilation
#-----------------------------------------------------------------------------
-configure_file (${HDF_RESOURCES_DIR}/H5pubconf.h.in ${HDF5_BINARY_DIR}/H5pubconf.h @ONLY)
+configure_file (${HDF_RESOURCES_DIR}/H5pubconf.h.in ${HDF5_SRC_BINARY_DIR}/H5pubconf.h @ONLY)
#-----------------------------------------------------------------------------
# Options for use by cross compiling and toolchains