summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2023-06-05 23:24:59 (GMT)
committerGitHub <noreply@github.com>2023-06-05 23:24:59 (GMT)
commitb5b1f4c7dfcc4a40af7c6c8ab1c89e49054f33c6 (patch)
treeb4dbd9c0f0b3fc4eb5999bb169c6f639a3c41772 /CMakeLists.txt
parentcd18732c2ee6e06384d5dfb033f9a9dc1c60ab0d (diff)
downloadhdf5-b5b1f4c7dfcc4a40af7c6c8ab1c89e49054f33c6.zip
hdf5-b5b1f4c7dfcc4a40af7c6c8ab1c89e49054f33c6.tar.gz
hdf5-b5b1f4c7dfcc4a40af7c6c8ab1c89e49054f33c6.tar.bz2
Update actions and change defaults of compression (fix vars) (#3043)
* Update actions and change defaults of compression (fix vars) * disable TS and parallel * remove parallel for TS * Correct list of default options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 2 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1e657fa..ca94ce4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -242,6 +242,8 @@ set (HDF5_JAVA_LOGGING_NOP_JAR ${HDF5_SOURCE_DIR}/java/lib/ext/slf4j-nop-1.7
set (HDF5_JAVA_LOGGING_SIMPLE_JAR ${HDF5_SOURCE_DIR}/java/lib/ext/slf4j-simple-1.7.33.jar)
set (HDF5_DOXYGEN_DIR ${HDF5_SOURCE_DIR}/doxygen)
+set (HDF5_SRC_INCLUDE_DIRS ${HDF5_SRC_DIR})
+
#-----------------------------------------------------------------------------
# parse the full version number from H5public.h and include in H5_VERS_INFO
#-----------------------------------------------------------------------------
@@ -637,16 +639,6 @@ if (MSVC)
set (WIN_LINK_FLAGS "")
endif ()
-set (MAKE_SYSTEM)
-if (CMAKE_MAKE_PROGRAM MATCHES "make")
- set (MAKE_SYSTEM 1)
-endif ()
-
-set (CFG_INIT "/${CMAKE_CFG_INTDIR}")
-if (MAKE_SYSTEM)
- set (CFG_INIT "")
-endif ()
-
# Do not generate test programs by default
option (HDF5_BUILD_GENERATORS "Build Test Generators" OFF)