summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2019-07-12 20:42:49 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2019-07-17 16:58:03 (GMT)
commit7ba562a82017779829394d5a5e03b62e69d6c926 (patch)
treeac5de2ce6f506844db708394297394fb143bcd71 /CMakeLists.txt
parentd586a457b2c3d0377b8752a6ce9b621a5994f56e (diff)
downloadhdf5-7ba562a82017779829394d5a5e03b62e69d6c926.zip
hdf5-7ba562a82017779829394d5a5e03b62e69d6c926.tar.gz
hdf5-7ba562a82017779829394d5a5e03b62e69d6c926.tar.bz2
HDFFV-10845 fix configure check and PATHs
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fc656c0..a62561f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -512,7 +512,7 @@ endif ()
# and we need to call the executable from inside the CMake configuration
#-----------------------------------------------------------------------------
set (EXE_EXT "")
-if (WIN32)
+if (WIN32 OR MINGW)
set (EXE_EXT ".exe")
add_definitions (-D_BIND_TO_CURRENT_VCLIBS_VERSION=1)
add_definitions (-D_CRT_SECURE_NO_WARNINGS)
@@ -688,7 +688,7 @@ endif ()
option (HDF5_ENABLE_THREADSAFE "Enable thread-safety" OFF)
if (HDF5_ENABLE_THREADSAFE)
# check for unsupported options
- if (WIN32)
+ if (WIN32 OR MINGW)
message (STATUS " **** thread-safety option not supported with static library **** ")
message (STATUS " **** thread-safety option will not be used building static library **** ")
endif ()