summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2019-01-31 01:32:40 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2019-01-31 01:32:40 (GMT)
commitf833001e3948c1088e09697c1b1820313e0d65e4 (patch)
tree097b9e60152f2ee2cb8bad1541174995768ba99b /CMakeLists.txt
parent9149d5a5352de4e0b9a2e57c91525a6cad767760 (diff)
downloadhdf5-f833001e3948c1088e09697c1b1820313e0d65e4.zip
hdf5-f833001e3948c1088e09697c1b1820313e0d65e4.tar.gz
hdf5-f833001e3948c1088e09697c1b1820313e0d65e4.tar.bz2
Updated sec2, log, and core VFDs to use pread/pwrite when
available (can be controlled via a configure/CMake option)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a16cb08..cb9839b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -482,6 +482,15 @@ if (HDF5_MEMORY_ALLOC_SANITY_CHECK)
endif ()
#-----------------------------------------------------------------------------
+# Option to enable/disable using pread/pwrite for VFDs
+#-----------------------------------------------------------------------------
+option (HDF5_ENABLE_PREADWRITE "Use pread/pwrite in sec2/log/core VFDs in place of read/write (when available)" ON)
+mark_as_advanced (HDF5_ENABLE_PREADWRITE)
+if (HDF5_ENABLE_PREADWRITE AND ${HDF_PREFIX}_HAVE_PREAD AND ${HDF_PREFIX}_HAVE_PWRITE)
+ set (H5_HAVE_PREADWRITE 1)
+endif ()
+
+#-----------------------------------------------------------------------------
# Option to use deprecated public API symbols
#-----------------------------------------------------------------------------
option (HDF5_ENABLE_DEPRECATED_SYMBOLS "Enable deprecated public API symbols" ON)